Welcome to Close Combat Series
  Login or Register Home  ·  Downloads  ·  Forums  ·  Combat Camera  ·  Help  

  Survey
TRIVIA: Are soldiers credited for killing surrendered troops?

Yes
No
Unsure



Results
Polls

Votes 2045
Comments: 2

  Shout Box!!

Only registered users can shout. Please login or create an account.

  Main Menu
Articles & News  
    Help
    Player`s News
    Site News
    Multiplayer
    Terrain Challenge
    Boot Camp
Community  
    Forums
    Downloads
    Combat Camera
    MOOXE @ Youtube
    TIK @ Youtube
    Statistics
Members  
    Private Messages
    Your Account
    Logout

  Donations
mikwarleo - $20.00
01/25/2019

0202243 - $10.00
12/04/2018

tycoon1969 - $10.00
07/31/2018

Anonymous - $10.00
06/24/2018

spudweasel - $5.00
05/19/2018

Schmal_Turm - $10.00
05/07/2018

gravyface - $5.00
02/06/2018

Anonymous - $0.00
11/14/2017

Anonymous - $0.00
11/14/2017

Anonymous - $0.00
11/14/2017

Find our site useful? Make a small donation to show your support.



Search for at
Close Combat Series Advanced Search


Goto page 1, 2  Next
 Author
Message
 
EagleEye

Rep: 13
votes: 1


PostPosted: Mon Apr 15, 2019 11:33 am Post subject: Can't see tree layer inside 5CC v1.22 Reply with quote

Hello, I am using the 5CC v1.22 tool made by mafi to open CC2 maps, everything works fine but I am not able to see the trees, even by following the manual of the tool the tree layer stays empty. Someone knows how to fix it?
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
ScnelleMeyer

Rep: 78.2
votes: 7


PostPosted: Tue Apr 16, 2019 1:41 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

I just opened some CC2 maps and I could display the tree layer without problems.
In "Edit" menu - select edit tree image overlay - then load the terrain file and you should see the trees if its checked in the "layer" menu.
Back to top
View user's profile Send private message
 
EagleEye

Rep: 13
votes: 1


PostPosted: Tue Apr 16, 2019 2:57 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Thanks for the answer, this is what I do: I go inside CC2 folder and I copy the relevant files for a map, like:

BGMAP320
map320
map320.los
MMMAP320
OVMAP320
ROOF320

I open map320 and it loads the other files, I see the map without trees, I go inside Edit > select edit tree image overlay.
I load the TERRAIN file that I've copied from the CC2 folder.
I still don't see any trees, to check I hide all the layers except for the tree layer and even this layer is empty.

I've tried this in OS X Sierra and even in Parallels with Win 8 and the result is the same. Could you share the map that you have tried to see if the issue is the with the default maps?
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
ScnelleMeyer

Rep: 78.2
votes: 7


PostPosted: Tue Apr 16, 2019 7:44 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

I have no problem opening map 320 or any other maps with trees displayed.

But I have not tried copying them to a different folder first.
Could you try just opening the map from its original location?
Back to top
View user's profile Send private message
 
EagleEye

Rep: 13
votes: 1


PostPosted: Wed Apr 17, 2019 10:34 am Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Did the same on a Windows system, opened the files from the original folder and exact same issue... Nothing inside the trees layer...
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
ScnelleMeyer

Rep: 78.2
votes: 7


PostPosted: Wed Apr 17, 2019 1:04 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

So its just the trees that fails to be displayed?
Roofs and interiors are displaying ok?

If its just the tree layer that fails, it seems the program fails to loaf the terrain file.

Can you try to load a map from a different CC version and check if trees will display for that map?
Back to top
View user's profile Send private message
 
ScnelleMeyer

Rep: 78.2
votes: 7


PostPosted: Wed Apr 17, 2019 1:06 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Could there be any file restrictions applied, preventing it from being read by 5CC?
Back to top
View user's profile Send private message
 
EagleEye

Rep: 13
votes: 1


PostPosted: Wed Apr 17, 2019 9:31 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

The weird issue is that on 3 different OS I have the same issue, all the rest is working fine, the terrain file doesn't give any errors
at this point I have another suspect... It could be an issue with the gog version? If you can attach the files of this map that you have opened I can try them
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
ScnelleMeyer

Rep: 78.2
votes: 7


PostPosted: Wed Apr 17, 2019 9:38 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Just download any map from the download section on this site to test your theory.
Back to top
View user's profile Send private message
 
southern_land

Rep: 109.7
votes: 13


PostPosted: Wed Apr 17, 2019 11:31 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

I think you have to link to the terrain file in one version of CC?
Back to top
View user's profile Send private message Send e-mail
 
EagleEye

Rep: 13
votes: 1


PostPosted: Thu Apr 18, 2019 8:41 am Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

I have used the terrain file inside the CC folder there are two files named in the same way, I've tried both of them but the result is the same, today I will try to download some maps of CC2 to see if I have the same issue
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
EagleEye

Rep: 13
votes: 1


PostPosted: Thu Apr 18, 2019 12:52 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Tried other maps from the mod section and the issue is always the same... No trees shown, even with user maps, the layer stays empty even if the terrain file is loaded correctly. On 3 different computers the issue is the same, so or I am doing something really stupid or the issue is the god version
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
ScnelleMeyer

Rep: 78.2
votes: 7


PostPosted: Thu Apr 18, 2019 1:20 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Can you see tree layers on CC3 maps?
Back to top
View user's profile Send private message
 
Mafi

Rep: 62
votes: 16


PostPosted: Thu Apr 18, 2019 5:03 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

EagleEye wrote (View Post):
I've tried this in OS X Sierra and even in Parallels with Win 8 and the result is the same. Could you share the map that you have tried to see if the issue is the with the default maps?


Hi EagleEye,

AFAIR the 5CC will remember the last used Terrain file. Perhaps this is gone in your case and you will see no trees therefore? So select a new Terrain file via: Menubar: Edit > Select tree image overlay > Button "Load file "Terrain". You wrote you did it this way, what is okay.

Now check your selection: below this button there also a line labeled "file path". There you will find the path of the actually loaded Terrain file. Just stay with the mouse over the text of this path and a tooltip will appear, showing the full path of Terrain file. So you can control which file you have really loaded.

If this file is missing on next start of 5CC, 5CC should ask for "a sprite file to load". In this dialog you can also select the disked Terrain file.

Next problem what might appear: you are using an unusual or empty terrain elements file (or perhaps no terrain elements file at all?) with no trees defined inside? In this case you will see also no trees.

I hope this helps a little bit, otherwise I must dug out my own old manual first.

Just made a test with old 5CC v1.17 on MacOS-X 10.14 and it works.

Cheers
Mafi
Back to top
View user's profile Send private message Visit poster's website
 
Drizzt

Rep: 96.9
votes: 8


PostPosted: Thu Apr 18, 2019 7:41 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Mafi wrote (View Post):
EagleEye wrote (View Post):
I've tried this in OS X Sierra and even in Parallels with Win 8 and the result is the same. Could you share the map that you have tried to see if the issue is the with the default maps?


Hi EagleEye,

AFAIR the 5CC will remember the last used Terrain file. Perhaps this is gone in your case and you will see no trees therefore? So select a new Terrain file via: Menubar: Edit > Select tree image overlay > Button "Load file "Terrain". You wrote you did it this way, what is okay.

Now check your selection: below this button there also a line labeled "file path". There you will find the path of the actually loaded Terrain file. Just stay with the mouse over the text of this path and a tooltip will appear, showing the full path of Terrain file. So you can control which file you have really loaded.

If this file is missing on next start of 5CC, 5CC should ask for "a sprite file to load". In this dialog you can also select the disked Terrain file.

Next problem what might appear: you are using an unusual or empty terrain elements file (or perhaps no terrain elements file at all?) with no trees defined inside? In this case you will see also no trees.

I hope this helps a little bit, otherwise I must dug out my own old manual first.

Just made a test with old 5CC v1.17 on MacOS-X 10.14 and it works.

Cheers
Mafi


Hi Mafi, your tools are awesome: I have always used them in a profitable way. I have a consideration to do about this problem, and a question about BED9:

1) About what it has reported EagleEye user, in your opinion, the problem could be a wrong terrain elements file loaded? Or, at the opposite point of view: trees location inside this file can cause this kind of problem with the wrong terrain file? For my mods I have always created a user-defined terrain elements file (tab limited for the tool) relative to the mod, so I don't remember which is the tool default file (terrain elements file). It's just an hypothesis (just to be clear for who read: terrain and terrain elements files are two different files).

2) About Bed9: I Know very well this tool, but there is a thing that I am always obliged to do manually: "Map view screen, overview map: red circle that shows which map this is on the strat map". In your tool, the coordinates are "not centered" with TLD (they don't match in the game: they aren't too distant, but don't match). In your opinion, it's a bug? It's something that sounds new for you? Maybe I do something of wrong or there is something that I don't know: you have some advice about this specific issue?
Back to top
View user's profile Send private message
 
EagleEye

Rep: 13
votes: 1


PostPosted: Fri Apr 19, 2019 12:45 am Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Mafi wrote (View Post):
EagleEye wrote (View Post):
I've tried this in OS X Sierra and even in Parallels with Win 8 and the result is the same. Could you share the map that you have tried to see if the issue is the with the default maps?


Hi EagleEye,

AFAIR the 5CC will remember the last used Terrain file. Perhaps this is gone in your case and you will see no trees therefore? So select a new Terrain file via: Menubar: Edit > Select tree image overlay > Button "Load file "Terrain". You wrote you did it this way, what is okay.

Now check your selection: below this button there also a line labeled "file path". There you will find the path of the actually loaded Terrain file. Just stay with the mouse over the text of this path and a tooltip will appear, showing the full path of Terrain file. So you can control which file you have really loaded.

If this file is missing on next start of 5CC, 5CC should ask for "a sprite file to load". In this dialog you can also select the disked Terrain file.

Next problem what might appear: you are using an unusual or empty terrain elements file (or perhaps no terrain elements file at all?) with no trees defined inside? In this case you will see also no trees.

I hope this helps a little bit, otherwise I must dug out my own old manual first.

Just made a test with old 5CC v1.17 on MacOS-X 10.14 and it works.

Cheers
Mafi


Thanks for the answer, I am loading the Terrain file inside the Graphics folder inside CC2, in game I see the trees so I suppose that the trees should be inside the file. I've checked multiple times insied the "edit tree image overlay" screen and the path is right and there is written the number of sprites loaded, but still the same issue, no trees. I can't try to open other CC maps because I don't have other games installed and so I can't have the Terrain file. Which CC version have you tested on Mac? It could be useful to try all this with the terrain file that you have used to test?
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
Mafi

Rep: 62
votes: 16


PostPosted: Fri Apr 19, 2019 5:03 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

EagleEye wrote (View Post):
... in game I see the trees so I suppose that the trees should be inside the file. I've checked multiple times insied the "edit tree image overlay" screen and the path is right and there is written the number of sprites loaded, but still the same issue, no trees. I can't try to open other CC maps because I don't have other games installed and so I can't have the Terrain file. Which CC version have you tested on Mac? It could be useful to try all this with the terrain file that you have used to test?


Hello EagleEye,

I have checked the CC2 Terrain file with LSA maps with the original CC2-Elements file. In such a case I see the trees not on the trunks but on the hedges, because the the maps are coded in LSA and not in CC2. But this doesn't matter. The tree layer is there and it's visibility can be toggled. Did you have toogled the visibility in the "Layer select window"? See also menubar item "Visibility", menu item "Show layer select".

Concerning BED9: might be a bug. No chance at the moment to dive into this problem. Sorry.

Cheers
Mafi
Back to top
View user's profile Send private message Visit poster's website
 
Drizzt

Rep: 96.9
votes: 8


PostPosted: Fri Apr 19, 2019 6:48 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Can I suggest to EagleEye to go in "preferences", "elements terrain table", and check if there is selected the CC2 terrain elements file? He can also search it (with "search" button) inside the tool folder named "TerrainElementsTable" to confirm that it's loaded correctly.
It seems to me to remember that once I didn't see the trees because terrain file and terrain elements file were not selected for the same CC version (or maybe terrain elements file was not selected/loaded at all).
Back to top
View user's profile Send private message
 
Tejszd

Rep: 134.2
votes: 15


PostPosted: Fri Apr 19, 2019 9:53 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Not helping solve the problem, but wanted to jump in to say THANK YOU again to Mafi for the great CC mod tools!


Last edited by Tejszd on Sun Apr 21, 2019 1:47 am; edited 1 time in total
Back to top
View user's profile Send private message
 
EagleEye

Rep: 13
votes: 1


PostPosted: Fri Apr 19, 2019 11:19 pm Post subject: Re: Can't see tree layer inside 5CC v1.22 Reply with quote

Drizzt wrote (View Post):
Can I suggest to EagleEye to go in "preferences", "elements terrain table", and check if there is selected the CC2 terrain elements file? He can also search it (with "search" button) inside the tool folder named "TerrainElementsTable" to confirm that it's loaded correctly.
It seems to me to remember that once I didn't see the trees because terrain file and terrain elements file were not selected for the same CC version (or maybe terrain elements file was not selected/loaded at all).


Thank you very much! It worked! I've already went inside the preferences and the file inside the archive was selected, had to point to the path manually and now the trees are there, thanks to everyone for the help!
Back to top
View user's profile Send private message Visit poster's website GameRanger Account
 
 
Post new topicReply to topic printer-friendly view Close Combat Series Forum Index -> Modding Workshop
Goto page 1, 2  Next


 
   
 


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum




Forums ©





In August of 2004, Zappi, Homba, Bambam887, RedScorpion and MOOXE all pitched
in to create this Close Combat site. I would to thank all the people who have visited and
found this site to thier liking. I hope you had time to check out some of the great Close Combat
mods and our forums. I'd also like to thank all the members of our volunteer staff that have
helped over the years, and all our users that contributed to this site!